Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Please read the forum rules before posting.



Check if you are posting in the correct category.



The Off Topic section is not meant for discussing Cookie Clicker.
⚠️ The DashNet forums will be shut down on September 12th 2019.⚠️

Please see here for more information.

Timer resources conflicting?

I have two 'hidden' timer resources in an IGM game I'm making right now. One is a 'birth' timer, which is ticked up by dragons and creates a new one when it reaches 100, then drains itself. The other is a 'growth' timer, which is ticked up also by the same dragons, and when it reaches 100, it *should* create an aged up version of that dragon(which is a new type of building) and drain. It ticks up to 100, drains, and nothing happens. However when I set the growth timer to give me another of the dragon that the birth timer gives, it works perfectly.

*fireBirth name:Fire Dragons Birth Rate desc:Creates new Fire Dragons when it reaches 100. on tick: if (fireBirth>=100) yield yoRd1Brd1Derg lose 100 fireBirth end end *yoRd1Brd1DergGrow name:YA Red Fire Dragon Growth Rate desc:Ages a dragon from Young Adult to Adult on tick: if (this>=100) yield adRd1Brd1Derg lose 100 yoRd1Brd1DergGrow end end

I've tried making it yield 1 instead of just yield, I've tried making it yield an upgrade which then yields the dragon, but that doesn't work either. It doesn't yield anything when the timer resets as it should, when the other timer I've made works flawlessly.
Sign In or Register to comment.