Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Please read the forum rules before posting.



Check if you are posting in the correct category.



The Off Topic section is not meant for discussing Cookie Clicker.

Pausing while minimized?

dddaaannndddaaannn Member Posts: 2
I have occasionally noticed the game pausing instead of running in the background after minimizing the browser window. I'm unable to reproduce this consistently, though it happened just now. I don't believe my computer is sleeping the OS when this happens (it wasn't this most recent time). Chrome 60.0.3112.90, Mac OS X 10.12.6. Is this a known issue or expected behavior under certain circumstances?

Comments

  • bob_32_116bob_32_116 Member Posts: 651 ✭✭✭
    Is "Defocus" set to ON? (Last item on the Options screen.)

    If so, I suspect that it's normal behaviour and that the game itself is not pausing, only the resource-intensive display actions are pausing. That is, production is continuing at the normal rate. You could check this by, say, minimising the window for a certain time, noting how much production happened in that time and calculating whether this is consistent with your CpS.

    On my system, if i set defocus on, when CC is not the foreground window the display becomes jerky, as though it's being "paused" for about one second at a time. Clearly what's happening is that the game is running happily as normal but the display is only being redrawn about once per second.

    If your defocus setting is OFF and you're still seeing this behaviour, I don't know what to suggest. Maybe your OS is implementing its own defocus behaviour, overriding the setting in CC. Either way I doubt it's affecting the number of cookies produced.
  • dddaaannndddaaannn Member Posts: 2
    I can confirm that the behavior that I'm seeing is that the game is completely paused under some circumstances where I expected it not to be. I just left it minimized overnight and when I opened it this morning, a 1-minute debuff that was in progress when I minimized still had 45 seconds on the clock, and none of the expected overnight cookie gains had taken place. (When re-opened, it proceeded as normal.)

    I'm pretty sure this is not about my laptop sleeping. At least in this most recent case, I don't think the machine should have gone to sleep until well after the 1-minute debuff had elapsed.

    If it helps to debug, Defocus was off. I actually didn't notice that option because I had assumed that that feature was automatic: my laptop fan runs up when the window is active and runs down when defocused. I routinely notice UI performance lags especially when the building pane is scrolled down some; I had assumed that was related to the ads. From what I'm seeing, this is unrelated to the unexpected pausing behavior.

    Not sure how to make this a useful bug report. Let me know what other info I can gather.
  • Lovett21Lovett21 Member Posts: 1
    I've started having the same issue yesterday. I have Defocus off and yet my game pauses even if I only switch tabs. I play on Chrome 61.0.3163.100 on a Windows PC. Let me know what kind of information you need in order to help you fix this issue.
  • RobaatoRobaato Member Posts: 10
    I had a similar issue, and posted about it in a thread that seems to have been buried... and the same solution (defocus) was offered, and nothing else was suggested after I and others said it didn't work. Hopefully someone will figure it out this time...
  • TV4FunTV4Fun Member Posts: 4
    I have just noticed the same issue cropping up in the last couple of days. Was there an update? I checked and Defocus is definitely set to off. Also tried reloading and turning Defocus on and off.
  • TV4FunTV4Fun Member Posts: 4
    It's possible this is due to a recent update to Chrome. In version 57, Chrome changed how it handled background tabs. I would really like to post a link to the page describing it, but I have not been around long enough. Do a Google search for chrome background javascript and it should be the second page. If you are running version 57 or later, this probably affects you.
  • BillaboBillabo Member, Friendly, Conversationalist Posts: 1,182 ✭✭✭✭
    You can post links if you delete the http://www. part (eg. google.com). But that does sound like a likely cause for this.
    Fire Emblem: Fates castle address
    08619-69569
    56318-03154
  • bob_32_116bob_32_116 Member Posts: 651 ✭✭✭
    Is this something that only happens to people using Chrome? I don't use Chrome, and I have never had this issue.

    An interesting thing to try would be to have two instances of the browser running simultaneously (not just two tabs) and see if the game still pauses when that particular instance of the browser is not in focus. If it does not, that would be a possible workaround.
  • TV4FunTV4Fun Member Posts: 4
    Here is the link: developers.google.com/web/updates/2017/03/background_tabs
Sign In or Register to comment.