Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Please read the forum rules before posting.



Check if you are posting in the correct category.



The Off Topic section is not meant for discussing Cookie Clicker.

The most confusing error I've encountered

LolkatLolkat Member Posts: 60 ✭✭
edited July 17 in Help
aka the mysterious building conundrum


ALRIGHT I'VE FIXED IT NEVER MIND: Though for those who are either ever experiencing the same thing or wish to know how this crazy little incident was resolved, here it is.

i had a clickable which produced too much on click
clicking it broke the whole game
I have no idea why that happens



I've been working on updating a more personal idle game I've made for me and my friends recently, mostly adding some improvements with upgrades icons and such, but after a solid multiple hours of work, I realized that there was some really peculiar activity regarding buildings.
For a little more background, the game has a primary resource, and then what I've dubbed 'primary-secondary' resources, like bricks from wall destroyer for a well-known example. There's also secondary things like All times, manual clicks, and building production stats.

First: No building is capable of producing the 'primary-secondary' resource under any circumstances. No matter how many you have, they won't produce.
Second: Only the last four buildings are able to produce the primary resource, but only when you have this many of each: 2, 3, 7, 10, 12. Otherwise it stays constant and will not increase.
This is where another oddity comes in: this is only the last four that can produce this primary resource first of all.
Third: Anything that is not primary (Manual clicks, all times, etc.) can be produced by every building perfectly fine without any issues whatsoever.

Note that everything has been code-named, but resource names and everything are consistent throughout.
Another note that I've tried multiple stylesheets to see if that was the problem, as well as rolling back the building stats thing for multiple buildings/in general to see if that would fix it, but it did not.
Another another note that the log fails to parse 0 lines.

Example of Non-functioning building for primary resources:
*Building1 -"Gives 1/PS." -costs 10 PrimaryResource -gives 1 PrimaryResource -gives 1 Building1ProdStat -gives 1 AllTimePR -named Building 1|Building 1 -visible -image : http://i.imgur.com/RF6q8qK.png


Example of Functioning, but only under certain circumstances building:
*Building13 -"Gives 100,000,000,000/PS." -costs 100000000000000 PrimaryResource -costs 100000 PRSResource -costs 200 PRSResource2 -costs 50 PRSResource3 -gives 100000000000 PrimaryResource -gives 100000000000 PrimaryResourceB13 -gives 100000000000 AllTimePR -gives 100 PRSResource -gives 100 PRSResourceB13 -gives 100 AllTime3 -gives 0.001 PRSResource2 -gives 0.001 PRSResourceB132 -gives 0.0001 PRSResource3 -gives 0.0001 PRSResourceB133 -named Building 13|Building 13 -hidden -image : http://i.imgur.com/RF6q8qK.png


I can provide more information upon request, any and all help/ideas/solutions are appreciated.

Testing done since this post:
Removing the upgrades section did not fix problem



lolkat the kitten clicker guy
Sign In or Register to comment.