Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Please read the forum rules before posting.



Check if you are posting in the correct category.



The Off Topic section is not meant for discussing Cookie Clicker.

Problem with identificators and attributes

frigcalfrigcal Posts: 4Member
edited January 2016 in General Discussion
orteil.dashnet.org/randomgen/?gen=2D2c65gY
^^^T his is the generator in question. I can't make it work for some reason. The problem is, roughly speaking, with the code parts:
$person regular jisoo
hot substitute teacher {match:student}

is [an] [#person1,as person,#noun1] and [#person1,as pair,#person2] is [an] [#noun1,as match,or #person2,as person,#noun2]. 

The goal was that after defining the #noun1 identifier, the other command should use the identifier and find it's attribute, but instead I'm getting the identifier instead. To illustrate, I'm getting:

"Jisoo is a hot substitute teacher, and Jeonghan is a hot substitute teacher."

instead of, for example

"Jisoo is a hot substitute teacher and Jeonghan is a student."

Also the part with hybrids/shapeshifting is failing me all the same.
Seokmin {animal:[cat|dog]}
Wonwoo {animal:cat}

[seokmin,as animal] shapeshifter {match:[#person2,as animal shapeshifter|regular dude]}
[wonwoo,as animal] shapeshifter {match:[#person2,as animal shapeshifter|regular dude]}

The result should be:

"Seokmin is a dog shapeshifter and Wonwoo is a cat shapeshifter."

but instead, I'm getting

"Seokmin is a [seokmin] shapeshifter and Wonwoo is a [seokmin] shapeshifter."

now, I honestly don't know how to fix it. Help the noob out?
Tagged:

Comments

  • frigcalfrigcal Posts: 4Member
    I edited a crapton of stuff and it's STILL. NOT. WORKING ; ; I'm losing hope. please. please please help. please.
  • Mac15001900Mac15001900 Posts: 104Member ✭✭✭
    It's been a while since I've done any Randomgen stuff so I don't exactly remember how all the attributes worked and can't exactly help you, but since nobody else is answering at least have some vague tips:
    1. There's quite a lot of bugs when it comes to dealing with attributes
    2. Try to isolate the issue. Have as little things as possible, make sure you're using them correctly while they still don't work. Make random changed to see exactly what works and what doesn't. It will give you an idea of how the bug works.
    3. Try doing it differently, so you don't have to deal with the bug.
    4. Or try to make random changes to make it work. I've once changed [thing] (which didn't work) into [[thing]|[thing]] (which did work).
Sign In or Register to comment.